Touchpad range: ([-100,+100], [-100,+100])

Go down

Touchpad range: ([-100,+100], [-100,+100]) Empty Touchpad range: ([-100,+100], [-100,+100])

Post by pgillich on Sat Oct 15, 2016 1:51 pm


I'm working on an ESP8266 project: ESP4S2
It's compatible with RoboRemo. I'd like to use RoboRemo touchpad to control the two DC motors of a tank chassis. The problem is, touchpad cannot send negative values. Example for negative coordinates: tankWrite 5 6 7 3 -100 -50
See more details at Tank Write

Is it possible to improve RoboRemo to handle negative coordinates?

I have another problem: how the sensor value sending work on UDP communication? I tried it, but RoboRemo level indicator does not work. What is the IP address and port where the values should be sent to? Example for value reporting to RoboRemo: "8 22\n", where "8" is the pin, "22" is the value which should be presented. I tried to response heartbeat too, but is did not work.


Posts : 3
Join date : 2016-05-22

View user profile

Back to top Go down

Touchpad range: ([-100,+100], [-100,+100]) Empty Re: Touchpad range: ([-100,+100], [-100,+100])

Post by Admin on Wed Oct 19, 2016 11:16 am

Yes, the negative values do not work in touchpad, it is a known bug, it will be fixed in the next version.

For UDP:
menu -> connect -> Internet (UDP)
enter ip:port
for example:
RoboRemo will send data to that port on that ip
RoboRemo will receive data on the same port, but the ip of the phone

For example if you have 2 phones connected to the same WiFi and
phone A has IP
phone B has IP

on phone A select menu -> connect -> Internet (UDP) ->
on phone B select menu -> connect -> Internet (UDP) ->

now the 2 phones are connected one to another.

Add a level indicator to one phone, set id to "8" (without "")
Add a button to other phone, set press action to "8 22" (without "")

Press the button and you should see the level indicator value goes to 22.

About sending "8 22\n" from microcontroller, make sure you are not sending "8 22\r\n" or "8 22\n\r" or "8 22" and also make sure the last character RoboRemo received before "8" was "\n".

Hope this helps,


Posts : 112
Join date : 2016-03-08

View user profile

Back to top Go down

Back to top

Permissions in this forum:
You cannot reply to topics in this forum